Views e acl’s no do bind9

 Clusterweb, ClusterWeb, Debian, Dns, Leitura Recomendada, Linux, Profissional de TI, Redes, Segurança  Comentários desativados em Views e acl’s no do bind9
jun 292018
 

Certo dia estava fuçando na internet usando o DIG que é uma ferramenta de lookup para DNS, e encontrei um domínio que tinha muitos registros do tipo A (host) apontando para endereços ip privados.

Bom se você tem os servidores de DNS na sua empresa ou entidade, você pode utilizar acl’s e views do BIND para criar uma zona específica para sua intranet e outra expecífica para uso externo.

Veja só, vamos editar o arquivo named.conf.local, presente no debian ou ubuntu.

Continue reading »

Manual:CHR MIKROTIK

 Clusterweb, ClusterWeb, Leitura Recomendada, Mikrotik, Profissional de TI  Comentários desativados em Manual:CHR MIKROTIK
jun 292018
 

Cloud Hosted Router

Cloud Hosted Router (CHR) is a RouterOS version intended for running as a virtual machine. It supports the x86 64-bit architecture and can be used on most of the popular hypervisors such as VMWare, Hyper-V, VirtualBox, KVM and others. CHR has full RouterOS features enabled by default but has a different licensing model than other RouterOS versions.

System Requirements

Minimal requirements:

  • RouterOS version 6.34 or later installed
  • 64bit CPU with virtualization support
  • 128 MB or more RAM for the CHR instance
  • 128 MB disk space for the CHR virtual hard drive
    • Maximum supported system disk image size is 16GB
Icon-note.png

Note: Minimal requirement is 128MB of RAM to complete the self-installation process.

 

Continue reading »

Migration of servers to Proxmox VE

 Clusterweb, Profissional de TI, Proxmox, Segurança, Virtualização  Comentários desativados em Migration of servers to Proxmox VE
jun 222018
 

Introduction

You can migrate existing servers to Proxmox VE. Moving Linux servers is always quite easy so you will not find much hints for troubleshooting here.

Windows systems specific P2V issues

inaccessible boot device

Booting a virtual clone (IDE) of a physical Windows system partition may fail with a BSOD referring to the problem

STOP: 0x0000007B (0xF741B84C,0xC0000034,0x00000000,0x00000000)
INACCESSIBLE_BOOT_DEVICE 

this means that the source physical windows machine had no support for IDE controller, or at least the one virtually replaced by kvm (see Microsoft KB article article for details): as Microsoft suggests, create a mergeide.reg file (File:Mergeide.zip) file on the physical machine and merge that in the registry, ‘before the P2V migration. Btw, it may not be necessary but should be no harm, anyway, and save you lots of time and headaches.

Continue reading »

jun 222018
 

INTRODUÇÃO

Pretendo abordar nesse tutorial a migração das máquinas virtuais do Citrix XenServer para o ProxMox. Por mais que a versão 6.2 do Citrix XenServer tenha se tornado 100% opensource, nunca fiquei 100% satisfeito com o XenCenter (ferramenta de gerenciamento do Citrix XenServer) ser disponibilizado apenas para Windows. Com isso,  fui obrigado a ter uma máquina virtual com Windows apenas para gerenciar os servidores Citrix Xen. Assim, surgiu o interesse em migrar para o KVM (Kernel-based Virtual Machine) que possui várias ferramentas de gerenciamento. Por considerar mais prática e intuitiva, a escolha feita foi pelo ProxMox VE.

 

EXPORTANDO A VM DO XENSERVER

É inegável que  XenCenter seja muito intuitivo. Mas na maioria das vezes, o procedimento de exportação de VM (Menu: VM>Export) não funciona corretamente:
citrix-export-error

Continue reading »

APACHE – COMPARTILHAMENTO DE RECURSOS – VIRTUALHOSTS

 Apache2, CentOS 7 / RHEL 7, Clusterweb, ClusterWeb, Debian, Hospedagem, Leitura Recomendada, Linux, Profissional de TI, Ubuntu  Comentários desativados em APACHE – COMPARTILHAMENTO DE RECURSOS – VIRTUALHOSTS
jun 192018
 

INSTALAÇÃO E CONFIGURAÇÕES DO APACHE

 

Recentemente me deparei com uma necessidade incomum em minha breve, mas ativa, carreira de desenvolvedor/suporte. Eu estava envolvido em alguns projetos distintos que precisavam ser disponibilizados para testes antes do uso efetivo das ferramentas, todos na mesma época e usando estruturas de pastas diferentes entre si.

A princípio, a resolução deste “problema” é simples, hospedar estes projetos em servidores diferentes ou jogar todos estes projetos no Document Root do Apache e referenciar os diretórios pela URL. Ok, funcionaria, mas, na ocasião, era necessário informar domínios diferentes para cada projeto.

Então, para que fique mais claro, o cenário era o seguinte:

  • Apenas um servidor para hospedar os projetos;
  • Projetos com estrutura de pastas diferentes;
  • Necessidade de uso de domínios diferentes para acessar cada projeto.

Na época encontrei diversas dicas como “crie um arquivo .httpsaccess na raiz do seu projeto…”, “altere o arquivo do framework X, caso seu projeto use esse framework…”, alguns como “crie um arquivo PHP com essa classe aqui…” e alguns engenhosos recomendando o cadastro regras de NAT do IPTables para usar portas diferentes e passar o link especificando a porta. Todas estas sugestões funcionariam? Sim, algumas demandando mais tempo, outras menos, mas, em minha opinião, nenhuma era a ideal.

Então, como resolver? A maioria das pessoas que conheço -me incluo aqui-, talvez pela facilidade de instalação e uso básico do Apache ou mesmo por ser uma situação incomum em ambientes pequenos, configurar mais de um site por servidor, “lê” guias de instalação do Apache e não se dão conta de que é possível hospedar diversos sites usando uma única instalação do Apache.

Basicamente, o que faremos é fazer com o que o Apache “leia” a URL e decida o que fazer de acordo com o endereço informado. Por exemplo:

  • Se o usuário indicar a URL “https://meusite.com.br”, redirecione a requisição pra pasta “meusite/”;
  • Se o usuário indicar a URL “https://projeto.com.br”, redirecione, então, para “projeto/public”;
  • Se o usuário indicar a URL “https://projeto.com.br/admdb”, redirecione para o diretório do PHPMyAdmin, que não tem nada a ver com o diretório “projeto”.

Continue reading »

jun 192018
 

ESTRUTURA DA TABELA E INSERÇÃO DE REGISTROS

O intuito deste artigo é compartilhar um pouco da minha experiência com migração de arquivos BLOB em um banco de dados Oracle para sistema de arquivos utilizando Python.

Antes de efetivamente partirmos para o código de migração, vamos ver os dados de acesso e como será a estrutura da tabela.

Utilizo os seguintes dados de acesso para o esquema no Oracle:

  • user: desv
  • pass: 123456
  • service name: xe
  • IP do host onde está o SGBD do Oracle: 192.168.1.131

Vamos utilizar a estrutura da tabela a seguir:

CREATE TABLE TB_ARQUIVO (
	COD_ARQUIVO           NUMBER PRIMARY KEY,
	DTHINCLUSAO           DATE NOT NULL,
	ARQUIVO               BLOB,
	DS_ARQUIVO            VARCHAR2(50 BYTE),
	DS_PATH_ARQUIVO       VARCHAR2(255 BYTE)
);

Continue reading »

jun 102018
 

Bloqueando FACEBOOK e outras redes sociais no RouterOS – Mikrotik

 Clusterweb, ClusterWeb, Firewall, Leitura Recomendada, Mikrotik, Profissional de TI, Redes, Segurança  Comentários desativados em Bloqueando FACEBOOK e outras redes sociais no RouterOS – Mikrotik
jun 032018
 

O bloqueio apesar de simples pode ser usando para qualquer site, já que é feito usado uma determinada string e portas de conexão.

O que fazemos é criar um regra de Layer7, contendo a string (REGEXP) com o nome que desejamos bloquear.

Após criar as regra de Layer7, crie uma regra de FORWARD bloqueando todos os pacotes que satisfazerem essa L7 nas portas 80(http) e 443(https).

Caso queira bloquear o próprio facebook, basta copiar e colar as regras no terminal do Mikrotik, lembrando que pode ser alterado a string (regexp) para “twitter” por exemplo.

1
/ip firewall layer7-protocol add name=facebook regexp=facebook
1
2
/ip firewall filter add action=drop chain=forward comment="facebook" \
disabled=no dst-port=80,443 layer7-protocol=facebook protocol=tcp

Artigo – Usando Storage Distribuído com Proxmox e Ceph

 Banco de Dados, Clusterweb, ClusterWeb, Debian, Leitura Recomendada, Linux, Profissional de TI, Redes, Segurança, Vlans  Comentários desativados em Artigo – Usando Storage Distribuído com Proxmox e Ceph
jun 012018
 

Porque usar Storage Distribuído com Proxmox

Quem trabalha com virtualização sabe dos benefícios em contar com um storage em sua estrutura. Pode ser um equipamento montado e instalado com FreeNas ou Nas4Free, pode ser um equipamento proprietário dos grandes players do mercado como IBM e Dell; são inúmeras às vantagens em relação a utilização das maquinas virtuais nos hds locais. Características como migração de Maquinas Virtuais (VMs) entre diferentes Hosts (Computador físico onde roda a VM) de forma on-line sem se preocupar com quedas de serviço; utilização de alta disponibilidade entre tantas outras. Este é o mundo dos storages centralizados tradicionais.

Continue reading »