ago 082020
 

Com as invasões de PCs, máquinas zumbis e outras coisas que podem ser um incômodo (principalmente quando se trata de um servidor), medidas de segurança nunca são demais.

Hoje, eu vou mostrar um simples script que criei para o IPtables. Eu fiz isso no Slackware 14.0, mas você poderá também executar este script em outra distribuição.

Bloqueando portas de entrada:

#!/bin/sh
#Iptables configuração.
#Script criado por Pangas

iptables -A INPUT -p icmp –icmp-type echo-request -j DROP
iptables -A INPUT -p tcp –destination-port 80 -j DROP
iptables -A INPUT -p tcp –destination-port 443 -j DROP
iptables -A INPUT -p tcp –destination-port 22 -j DROP
iptables -A INPUT -p tcp –destination-port 1234 -j DROP
iptables -A INPUT -p tcp –destination-port 21 -j DROP
iptables -A INPUT -p tcp –destination-port 12345 -j DROP
iptables -A INPUT -p tcp –destination-port 20 -j DROP

A opção -A INPUT diz que o Firewall deverá bloquear todas as portas de entradas que forem definidas. Nesse caso, eu resolvi criar um script que possa ser usado tanto em computadores domésticos, quanto em servidores.

Podem ver, que eu bloqueei também a porta do X e a porta padrão do NetBus. Pois fiquei sabendo de patches para GNU/Linux. Nenhum sistema operacional é 100% seguro, tanto que, até o Android da Google também é infectado.

A opção -p indica o protocolo. Você pode usar TCP ou UDP.

Já a –destination-port indica a porta de destino. Ou seja, qual serviço deve ser bloqueado ou liberado pelo IPtables. A opção -j DROP indica que a porta será bloqueada. Deve ser definida logo após a porta destino.

Bloqueando FACEBOOK e outras redes sociais no RouterOS – Mikrotik

 Clusterweb, ClusterWeb, Firewall, Leitura Recomendada, Mikrotik, Profissional de TI, Redes, Segurança  Comentários desativados em Bloqueando FACEBOOK e outras redes sociais no RouterOS – Mikrotik
jun 032018
 

O bloqueio apesar de simples pode ser usando para qualquer site, já que é feito usado uma determinada string e portas de conexão.

O que fazemos é criar um regra de Layer7, contendo a string (REGEXP) com o nome que desejamos bloquear.

Após criar as regra de Layer7, crie uma regra de FORWARD bloqueando todos os pacotes que satisfazerem essa L7 nas portas 80(http) e 443(https).

Caso queira bloquear o próprio facebook, basta copiar e colar as regras no terminal do Mikrotik, lembrando que pode ser alterado a string (regexp) para “twitter” por exemplo.

1
/ip firewall layer7-protocol add name=facebook regexp=facebook
1
2
/ip firewall filter add action=drop chain=forward comment="facebook" \
disabled=no dst-port=80,443 layer7-protocol=facebook protocol=tcp