abr 242019
 

Resumo

A alta disponibilidade compõe-se por uma arquitectura de dois ou mais computadores configurados para que possam trabalhar em conjunto. Desta forma, cada computador monitoriza os demais e em caso de falha assume os serviços que ficaram indisponíveis. Neste projecto são abordadas questões relativamente a hardware e software, privilegiando as soluções de alta disponibilidade baseadas em software. No mercado existem várias soluções para alcançar esse objectivo, mas o elevado custo de implementação e licenciamento impede a adopção desses sistemas por empresas economicamente limitadas. Para contornar essa limitação, foi utilizado software Open Source que permite a implementação de alta disponibilidade a baixo custo. Neste projecto é abordada a alta disponibilidade em servidores Web, recorrendo a software de código aberto e hardware vulgar. No capítulo direccionado aos conceitos básicos são apresentados alguns conceitos necessários para a compreensão do projecto, de seguida são explicados os diferentes tipos de cluster e respectivas vantagens de implementação, posteriormente os pontos de falha existentes nos sistemas computacionais bem como possíveis soluções. Finalmente é apresentada uma solução que garante alta disponibilidade através da utilização dos softwares Heartbeat, Keepalived, Haproxy, Apache, Mysql, GlusterFS e do módulo Bonding. Embora o objectivo deste projecto seja direccionado para os servidores Web, é possível recorrer aos mesmos mecanismos na implementação de outras soluções que exijam alta disponibilidade.

 

Continue reading »

dez 072018
 

CONFIGURANDO O APACHE2 DO PRIMEIRO SERVIDOR

Vamos começar instalando o apache2 e algumas libs:

 sudo apt-get install apache2 php7.2 libapache2-mod-php7.2
$ sudo apt-get install libapache2-mod-auth-mysql php7.2-mysql
$ sudo apt-get install apache2-prefork-dev

Habilitando os módulos do apache para o redirecionamento e para o proxy pass:

 sudo a2enmod env proxy_ajp proxy_balancer proxy proxy_connect proxy_http rewrite ssl headers

Para desabilitar os mods basta usar:

 sudo a2dismod [nome-dos-módulos]

Agora iremos criar o arquivo na pasta do apache2:

 sudo nano /etc/apache2/sites-available/meuSite

Continue reading »

jun 062017
 

a) WPAD could be set automatically (only in Internet Explorer) from DHCP – you have to add DHCP option, for example:

/ip dhcp-server option
add code=252 name=auto-proxy-config value=http://wpad.intranet/wpad.dat

(where value is address of your wpad script) and then use it in DHCP server network, for example:

/ip dhcp-server network
add address=192.168.100.0/24 dhcp-option=auto-proxy-config dns-server=192.168.100.1 gateway=192.168.100.1

Continue reading »

SEGURANÇA DE WEB APIS DISTRIBUÍDAS

 Apache2, Clusterweb, ClusterWeb, Hospedagem, Leitura Recomendada, Linux, Profissional de TI, Segurança, Ubuntu  Comentários desativados em SEGURANÇA DE WEB APIS DISTRIBUÍDAS
jan 292017
 

RESUMO

 

Artigo faz parte da disciplina de “Segurança de Sistemas”, do professor Elgio Schlemer.

Neste artigo são descritas as formas de autenticação e autorização de REST apis distribuídas, os motivos que aumentam a complexidade de desenvolvimento dessas futures em web services escalonados e as soluções baseadas nas melhores práticas em relação à essas arquiteturas.

Também é abordado a importância da criação de sistemas seguros, evidências que demonstram como esse problema impacta desde pequenas startups até grandes empresas, a gravidade da ciência do nível de criticidade e risco em relação aos softwares desenvolvidos e a importância de expor apenas recursos que sejam realmente necessários.

Serão mencionados também os perigos relacionados aos ataques de Man-in-the-middle, negação de serviço, SQL inject, JSON inject e os métodos utilizados para combatê-los.

INTRODUÇÃO

Informações sigilosas são expostas diariamente e esse problema não atinge apenas jovens startups que não tem o devido investimento na área, com frequência surgem notícias de grandes empresas que são hackeadas e acabam vazando dados indesejados. Somente neste ano, o Yahoo! afirmou que quinhentos milhões de contas foram hackeadas. No Dropbox foram mais de sessenta milhões e a Anatel teve seu banco de dados invadido. Inclusive grandes organizações como NASA e ESA não ficam fora dessa lista.

Softwares com suas arquiteturas baseados em micro serviços, orquestração e coreografias são termos cada vez mais citados na comunidade de desenvolvimento web. E todas as abordagens tem uma característica em comum: REST APIs. Elas estão por toda a parte.

Com o crescimento exponencial de estratégias digitais em mobilidade, cloud computing, mídias sociais e dispositivos inteligentes da Internet das Coisas, empresas de todos os tamanhos e setores estão desenvolvendo e expondo seus Web Services. Mas como sempre no mundo da computação, nem tudo são flores: junto com várias vantagens relacionadas à utilização de APIs distribuídas, também existem grandes problemas a serem resolvidos, e uma das maiores dificuldades é a segurança desses sistemas.

mar 142015
 

INTRODUÇÃO

 

Os Servidores Web são componentes essenciais em uma rede, onde disponibilizam uma infinidade de serviços, no entanto, são dispositivos eletrônicos e estão sujeitos a falhas, tanto físicas quanto lógicas.

Os responsáveis pelo gerenciamento dos servidores utilizam uma gama de recursos para aumentar e garantir a disponibilidade de acesso aos serviços disponibilizados, como Nobreaks, conexões de rede redundantes, entre outras soluções, mas uma falha pode causar enormes prejuízos e perda da credibilidade de qualquer setor.

Os fabricantes dos equipamentos dedicam uma atenção especial no desenvolvimento de componentes com proteção e que possuam o mínimo de pontos críticos de falhas. Desta forma, é comum encontrarmos em servidores Web conexões redundantes, que se alternam em caso de falhas de conexão, sistemas que registram em dois ou mais discos o mesmo arquivo e fontes de energia que se alternam entre falhas elétricas.

A arquitetura da rede de computadores possui premissas de configuração para reduzir os pontos críticos de falhas, componentes específicos como Nobreaks e geradores à combustível, que visam garantir energia elétrica suficiente para manter operante os Servidores Web e componentes de rede necessários.

Dominar as técnicas de tolerância de falhas torna-se essencial aos desenvolvedores e projetistas para disponibilizar um serviço de qualidade e que possa se recuperar de forma eficiente. O custo-benefício é outro ponto importante que deve ser levado em consideração, pois o investimento em tecnologia de prevenção de falhas é muito bem visto e possui um mercado mundial em crescimento, onde alguns serviços de larga escala estão hospedados em mainframes de alto custo, mas garantem alta disponibilidade.

O conceito de Alta Disponibilidade não se restringe apenas à arquitetura da rede, mas sim a todo e qualquer tipo de falha de disponibilidade como parte física, servidores, discos e rede. Visando garantir Alta Disponibilidade a serviços críticos, surgem sistemas alternativos com hardware acessível, chamado de Cluster, que é um agregado de computadores interligados em rede que possui alta escalabilidade e custo mínimo.

Continue reading »

set 052014
 

Não sei o que acontece.

O proxy está lá funcionando, configurado, sempre trabalhou inteiro e perfeito.

Do nada, começou a chegar uma certa hora do dia, ou não sei se é tráfego na rede….
Ele fica stopped e some as portas, as configurações dele…
Aí reinicio ele via terminal e tudo volta ao normal até apresentar o problema de novo

E fica nessa de funciona por um tempo. Para…

Alguém sabe me indicar um norte pra ir investigar isso ?

 

Desde já agradecido.

Shell Script para WEB

 Clusterweb, Leitura Recomendada, Shell Script  Comentários desativados em Shell Script para WEB
abr 102014
 

 

Iniciando / Variáveis de ambiente

Iniciando

Nas configurações padrões do Apache, existe um diretório já pré-definido para scripts CGI rodarem. É o /usr/lib/cgi-bin/.

Irei criar um arquivo com o nome tutorial.sh. Nos scripts CGI, a saída dos scripts (/dev/stdout e /dev/stderr), são enviadas para o cliente, as primeiras linhas do script serão o cabeçalho de resposta da requisição HTTP.

Desse modo, podemos forçar o download de arquivos, fazer redirecionamentos, etc, a quebra de linha é que separa o que será o cabeçalho e o que será o resto da resposta.

Voltando ao arquivo tutorial.sh, dentro do arquivo, coloque as seguintes linhas:

#!/bin/bash
echo -e “Content-Type: text/plain\n”    # É o Cabeçalho, e a quebra de linha
echo “Hello World”    # Agora é o resto do request, o conteúdo que é exibido pelos navegadores.

Salve o arquivo e deixe as permissões como 775 (lembrando: r = 4, w = 2, x = 1).

Acesse o link: http://localhost/cgi-bin/tutorial.sh E verá a mensagem: Hello World

Por padrão, o Apache já configura o cabeçalho de resposta.

Se não quiser, você pode pôr no começo do script: echo -e “\n” ou printf “\n\n”, e deixar que o Apache configure o cabeçalho, que normalmente, será algo parecido com isso:  Continue reading »

Web proxy Mikrotik com controle de acesso

 Clusterweb, Leitura Recomendada, Mikrotik  Comentários desativados em Web proxy Mikrotik com controle de acesso
fev 222014
 
Passos iniciais

A partir de agora temos um servidor Mikrotik com web-proxy configurado de forma liberal, ou seja, sem nenhuma restrição para acesso a internet, também não importa muito se o seu web-proxy é totalmente Mikrotik ou se funciona em paralelo, se você ainda não tem um web-proxy configurado, aconselho esta leitura antes de continuar lendo este artigo:

Vamos trabalhar com a classe 192.168.0.0/24 sendo a classe de clientes, que servirá como exemplo para todo o artigo.

Abaixo você verá uma figura que demonstra qual cenário queremos obter com as restrições.

Topologia e as opções de permissão

Na figura abaixo vemos a topologia da situação.

Continue reading »